WordPressのPHPバージョン動作環境

WordPress
このページはWordPressご利用の方が対象です

このページは、2021年09月10日に作成したページです。
このページに掲載しているWordPressの仕様・機能・操作手順は、現在リリースされている最新バージョンのWordPressと異なる場合がございます。

WordPressバージョンとPHPバージョンの関係

リリースされるWordpressは、現在ご利用中のサーバーにインストールされているPHPが古いバージョンの場合、インストールできない場合があります。

現在利用中のサーバーにインストールされたPHPで、アップグレードできるWordpressバージョンは、WordPressバージョンとPHPバージョンの対応表をご確認ください。

 

動作するPHPバージョンではない場合

WordPressの更新をした際に、現在ご利用中のサーバーにインストールされているPHPが古い為、特定バージョン以上のWordpressにアップグレードできない場合は、インストールされているPHPで動作するWordPressバージョンまでは、アップグレードされますが、次の様に表示されます。

動作するPHPバージョンではない場合

 

推奨する対応

脆弱性が発覚していないWordpressバージョンをご利用する分には、特に問題はございませんが脆弱性が発覚したWordpressバージョンを使い続ける事は危険です。

使用しているWordPressに脆弱性が発覚しているか確認するには、JVN iPediaのサイトで確認してください。

使用しているWordPressに脆弱性が発覚している場合は、最新のWordpressバージョンを利用する為に、サーバー側の対応が必要となります。

 

上位VerのPHPへ切り替えが可能な場合

サーバーによっては、使用できるPHPバージョンが選択できる機能がございます。

一番新しいPHPバージョンに切替をする事をお勧め致します。

 

上位VerのPHPへ切り替えができない場合

利用中のサーバー事業者にPHPバージョンのアップグレードが出来ないかご相談ください。

アップグレードが出来ない場合は、別のサーバーへの乗り換えをご検討ください。

 

 

推奨するPHPバージョンではない場合

最新のWordPressが動作しても、PHPが推奨バージョンよりも低い場合は、次の様に表示されます。

推奨するPHPバージョンではない場合

 

推奨バージョンよりも低いPHPバージョンであった場合でも、動作バージョンのWordPressはインストールできます。

但し、そのWordPressに合わせてアップグレードされた一部のプラグインが動作しない事がございます。

また、近い将来リリースされるWordPressバージョンで動作対象から外れる事が予測できますので、緊急ではありませんが最新のPHPバージョンへの切替(切替不可の場合は、サーバー乗り換え)を計画してください。

 

 

WordPressバージョンとPHPバージョンの対応表

WordPress
バージョン
動作する
PHPバージョン
推奨される
PHPバージョン
WordPress
リリース日
4.0 5.2.4 ~ 5.6 5.6以上 2014年9月4日
4.4~4.6 5.2.4 ~ 7.0 5.6以上 4.4 - 2015年12月8日
4.5 - 2016年4月12日
4.6 - 2016年8月16日
4.7 ~ 4.8 5.2.4 ~ 7.1 7.0以上 4.7 - 2016年12月6日
4.8 - 2017年6月8日
4.9.0~4.9.4 5.2.4 ~ 7.2 7.0以上 4.9 - 2017年11月15日
4.9.5 ~ 4.9.x 5.2.4 ~ 7.2 7.2以上 4.9.5 - 2018年4月3日
5.0 ~ 5.1 5.2.4 ~ 7.3 7.3以上 5.0 - 2018年12月6日
5.1 - 2019年2月21日
5.2 5.6.2 ~ 7.3 7.3以上 5.2 - 2019年3月7日
5.3 ~ 5.4 5.6.2 ~ 7.3 7.3以上 5.3 - 2019年11月12日
5.4 - 2020年3月31日
5.5 5.6.2 ~ 7.4 7.4以上 5.5 - 2020年8月11日
5.6 5.6.2 ~ 8.0 7.4以上 5.6 - 2020年12月8日
5.7 ~ 5.8 5.6.2 ~ 8.0 7.4以上 5.7 - 2021年3月9日
5.8 - 2021年7月20日